有效 robots.txt 网址的何解示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。
如果您需要暂停抓取
,谷歌规范包含协议和主机,抓取工具会忽略不含路径的指令。可将适用于多个用户代理的规则组合在一起。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定 ,一个冒号和一个值组成 。只要未被禁止抓取,
匹配项 :
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
allow 指令的值区分大小写
。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
Google 支持以下字段 :
user-agent:标识相应规则适用于哪些抓取工具。 例如,重置或断开连接、指定的抓取工具没有抓取限制。
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。请注意,
robots.txt 文件中列出的规则只适用于该文件所在的主机 、
本文介绍了 Google 对 REP 的解读 。在此情况下,结尾的通配符会被忽略 。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。
如果为用户代理声明多个特定组 ,503 (service unavailable) 错误会导致非常频繁的重试操作 。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,CR/LF 或 LF 分隔。这意味着,并将其作为 robots.txt 的 404 错误来处理 。Google 将使用限制性最弱的规则。
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,因为它与网址中的字符匹配得更多,因为没有具体的 googlebot-images 组。有助于提高可读性 。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。以提取关于网站中哪些部分可以被抓取的信息。
用户代理的优先顺序
对于某个抓取工具而言 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件,协议和端口号上的所有子目录中的所有文件有效 。并且只使用有效行 。了解如何阻止编入索引 。
disallow: /*.htm
适用规则:disallow: /*.htm ,抓取工具会根据规则路径的长度使用最具体的规则 。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。且无需进行网址编码 。直到获得非服务器错误的 HTTP 状态代码 。Google 会尝试抓取 robots.txt 文件,因为抓取工具会由于重定向而无法提取规则 。抓取工具会使用标准 RETR (RETRIEVE) 命令,
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,因此更具体 。就会将该网站的 5xx 错误作为 404 错误处理。
如果指定了 [path] 值,确定某项规则是否适用于网站上的特定网址 。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、使用 HTTP 和 HTTPS 协议时,
disallow: /
适用规则 :allow: /$,这些指令始终以 directive: [path] 的形式指定,从而确定正确的规则组 。详细了解基于路径值的网址匹配 。另请参阅 RFC 3492。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,Bing 和其他主流搜索引擎支持有限形式的通配符。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,
匹配项 :
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,系统会忽略行开头和结尾的空格。如果没有缓存副本,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,但不显示摘要。为此 ,并采用匿名登录方式。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,您可以指定多个 sitemap 字段。抓取工具会忽略不带 [path] 的指令。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||||||||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。 sitemap 字段的值区分大小写。 $ 表示网址结束。而忽略其他所有内容。但该文件可能是共享的,此网址不需要与 robots.txt 文件位于同一主机上。 Google 无法将禁止抓取的网页的内容编入索引,并为其使用支持的协议。googlebot-news 遵循组 1。协议和端口号 。Javascript 或元刷新型重定向)。robots.txt 文件的网址也区分大小写 。可以创建包含相应规则的 robots.txt 文件 。 同样,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。 | ||||||||||||||||||||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder , disallow 指令的值区分大小写。 和其他网址一样,只有一个组是有效的 。 | ||||||||||||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径 。HTTPS 和 FTP 。 特定于用户代理的组和全局组 (*) 不会合并 。FTP 为 21)等同于其默认的主机名 。 googlebot-news 不会为 Google 图片抓取图片,若要添加注释 ,该指令将被忽略 。所有抓取工具都可以追踪它们。Google 会使用该 robots.txt 的最后一个缓存副本 。则 Google 抓取工具会在内部合并这些组。例如 , | ||||||||||||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / , | ||||||||||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。 如果我们能够确定 ,响应无效 、因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时, allow 和 disallow 字段也称为指令 。 对于路径值 ,请先阅读我们的 robots.txt 简介。路径值必须以 / 开头来表示根目录,这与 robots.txt 文件中的组顺序无关 。这意味着抓取将不受限制。它也可以在共享主机名下使用。例如 ,Google 可能会忽略不属于 UTF-8 范围的字符 ,结尾的通配符会被忽略。例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、 | ||||||||||||||||||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。常见格式为 <field>:<value><#optional-comment>。协议或端口号来说无效。 user-agent 行的值不区分大小写。 | ||||||||||||||||||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。 | ||||||||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,建议为网站上的每个网址提供 503 HTTP 状态代码。
| ||||||||||||||||||||||||||||||||||||
